Author Topic: error generando una tabla de referencias cruzadas  (Read 2735 times)

nrub

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
    • View Profile
error generando una tabla de referencias cruzadas
« on: Julio 09, 2008, 01:38:57 pm »
Hola.

estoy trabajando con ireport y al generar un crosstab (una tabla de referencias cruzadas) me da el siguiente error
Error rellenando la impresión... Error incrementing crosstab dataset

net.sf.jasperreports.engine.JRRuntimeException: Error incrementing crosstab dataset      at net.sf.jasperreports.engine.fill.JRFillCrosstab$JRFillCrosstabDataset.customIncrement(JRFillCrosstab.java:666)      at net.sf.jasperreports.engine.fill.JRFillElementDataset.increment(JRFillElementDataset.java:169)      at net.sf.jasperreports.engine.fill.JRCalculator.calculateVariables(JRCalculator.java:152)      at net.sf.jasperreports.engine.fill.JRVerticalFiller.fillDetail(JRVerticalFiller.java:682)      at net.sf.jasperreports.engine.fill.JRVerticalFiller.fillReportContent(JRVerticalFiller.java:275)      at net.sf.jasperreports.engine.fill.JRVerticalFiller.fillReport(JRVerticalFiller.java:117)      at net.sf.jasperreports.engine.fill.JRBaseFiller.fill(JRBaseFiller.java:879)      at net.sf.jasperreports.engine.fill.JRBaseFiller.fill(JRBaseFiller.java:782)      at net.sf.jasperreports.engine.fill.JRFiller.fillReport(JRFiller.java:63)      at net.sf.jasperreports.engine.JasperFillManager.fillReport(JasperFillManager.java:402)      at net.sf.jasperreports.engine.JasperFillManager.fillReport(JasperFillManager.java:234)      at it.businesslogic.ireport.IReportCompiler.run(IReportCompiler.java:947)      at java.lang.Thread.run(Unknown Source)  Caused by: net.sf.jasperreports.engine.JRException: Crosstab data has already been processed.      at net.sf.jasperreports.crosstabs.fill.calculation.BucketingService.addData(BucketingService.java:296)      at net.sf.jasperreports.engine.fill.JRFillCrosstab$JRFillCrosstabDataset.customIncrement(JRFillCrosstab.java:662)      ... 12 more 
Iimpresión no llenada. Intento usando una Fuente de datos vacia...

No se a que puede ser debido.

Agradeceria cualquier tipo de ayuda que me ayude a solucionarlo.

Muchas gracias

 

ey