Author Topic: Problema inicio con maven  (Read 6125 times)

Lute_

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Problema inicio con maven
« on: Diciembre 15, 2009, 12:25:35 am »
Hola tengo un probelma, estoy empezando a utilizar el plugin de eclipse de maven y al crear un proyecto e intentar añadir alguna dependencia, la lista de dependencias me sale vacia. No se si me las tengo que bajar de antemano o puedo ir añadiendo desde el servidor remoto segun me vaya viniendo bien. Utilizo el setting.xml que viene por defecto cuando me baje el maven, no se si deberia modificar algo.

Muchas gracias de antemano

chuidiang

  • Administrator
  • Hero Member
  • *****
  • Posts: 5468
  • Karma: 12
    • View Profile
    • Apuntes de programación
Re: Problema inicio con maven
« Reply #1 on: Diciembre 15, 2009, 04:31:21 am »
¿Qué quiere decir "la lista de dependencias me sale vacía"? ¿Cómo sacas esa lista?

Se bueno.

Lute_

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Re: Problema inicio con maven
« Reply #2 on: Diciembre 15, 2009, 05:52:40 pm »
Con el plugin de eclipse de maven.

Con el boton derecho pulsas encima del proyecto y vas a maven-->Add Dependency

entonces te sale una pantalla para buscar y se supone que si buscas una libreria que se encuentra en el repositorio general por ejemplo pues deberia salir, pero a mi no me sale nada

chuidiang

  • Administrator
  • Hero Member
  • *****
  • Posts: 5468
  • Karma: 12
    • View Profile
    • Apuntes de programación
Re: Problema inicio con maven
« Reply #3 on: Diciembre 15, 2009, 07:38:11 pm »
No uso plugin de eclipse, suelo hacerlo a mano tocando directamente en el pom.xml

Normalmente las dependencias hay que añadirlas de algún repositorio de librerías al estilo maven. Es posible que en algún sitio de configuración de ese plugin de elipse haya que añadir cuales son esos repositorios. Por ejemplo, el repositorio estándar de maven en el que están la mayoría de las librerías más comunes está en http://repo1.maven.org/maven2/ Mira a ver si en eclipse tienes forma de incluir esta URL en alguna de las ventanas de configuración del plugin.

Se bueno.

karakulak

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Re: Problema inicio con maven
« Reply #4 on: Febrero 19, 2010, 04:45:04 am »
Hola yo tengo otra duda. Resulta que intentando generar el javadoc del proyecto del ejemplo del tutorial:

http://www.chuidiang.com/java/herramientas/maven.php

con el comando mvn javadoc:javadoc obtengo un error indicando que no puede abrir ciertos .zip ubicados en mi repositorio local .m2. El error me indica que esos .zio se corresponden con las dependencias: mail-1.4 de javax.mail, jmxri, jms-1.1, jmxtools-1.2.1. De manera que navegando por el explorador de archivos de windows hasta localizarlas, al abrirlas me indica que el fichero está corrupto, Según lo que he encontrado la solución es substituir el fichero por el .jar que se ubica en el repositorio (http://www.ibiblio.org/maven2/ en este caso). Puesto que son muchos ficheros:
¿Es posible realizar una descarga de todos de alguna forma y tener que ir 1 por 1?
¿Es posible realizar una descarga completa del repositorio .m2, es decir, lo que hace maven la primera vez que tiene que dirigirse al repositorio para descargarse las dependencias?

Muchas gracias y un saludo

chuidiang

  • Administrator
  • Hero Member
  • *****
  • Posts: 5468
  • Karma: 12
    • View Profile
    • Apuntes de programación
Re: Problema inicio con maven
« Reply #5 on: Febrero 19, 2010, 05:11:04 pm »
Hola:

La mejor forma es que borres de tu .m2 todos los ficheros corruptos (o incluso una estructura de directorios completa si quieres). Luego, cuando hagas el siguiente comando de maven, te bajará nuevamente todo lo que necesite.

No hay una forma de bajarse el repositorio completo, pero maven si se baja automáticamente todo lo que necesita según ejecutas comandos, por lo que no debería suponerte ningún problema.

Se bueno.

 

ey