Author Topic: Consulta sobre Java RMI  (Read 2414 times)

Panic

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Consulta sobre Java RMI
« on: Julio 30, 2010, 07:45:08 am »
Tengo una duda, no se si esta es la zona indicada para plantearla pero, se relaciona con J2ME. :P:P

Resulta que tengo desarrollado en java una aplicacion que accede a una base de datos. Por otro lado tengo una PDA que es un scaner de mano. Este scaner tiene un windows CE como sistema operativo.
Quise desarollar una interfaz utilizando Java RMI para que la PDA pueda realizar consultas a la base de datos.

La interface la desarrolle y la probe con un pc de escritorio, hasta ahi no hay problemas anda todo como corresponde. El tema es cuando paso la aplicacion a la PDA. Cuando intento acceder a la base de datos usando RMI la aplicacion arroja el siguiente error:

java.rmi.unmarshalexception error unmarshalling return nested exception is java.io.streamCorruptedException: Type code out of range, is 125

Me puse a buscar en internet y me encontre con un posible error. La PC que tiene el servidor RMI ejecuta una de las ultimas versiones de Java (jdk1.6.0_10 y jre6.0). Mientras que la PDA tiene una JVM que se llama personalJava, que segun la documentacion se corresponde con el JDK 1.18.xxx

Es posible que el error se de por esta diferencia de versiones? es posible solucionarlo ?

 

ey