Author Topic: bloque div que se ve bien en explorer pero no en firefox  (Read 3326 times)

alemag

  • Sr. Member
  • ****
  • Posts: 289
  • Karma: 0
    • View Profile
bloque div que se ve bien en explorer pero no en firefox
« on: Septiembre 30, 2010, 08:19:45 pm »
Buenas tardes, quiero sacar por pantalla en una linea un texto ("Sin documento adjunto", lo tengo en etiqueta span) y un enlace ("Anadir documento"). Todo en la misma línea. En el explorer se ve bien, pero en el firefox, el enlace me lo muestra en otra linea distinta. A que puede ser debido ??

Es la primera parte del codigo, pero pego los bloques que puse luego por si tienen relacion:

<fieldset class="bloqueFieldset">
<legend><bean:message key="Otros_Datos"/></legend>

<fieldset class="bloqueFieldsetSinBordeSinMargen">
<div class="bloqueLineaAdjuntos">
  <div class="bloqueCampoAdjuntos">
    <div class="bloqueCampo bloqueBotonAddArchivo">            <span id="docAdjunto" style="margin-left: 15em"><bean:message key="Sin_Documento_Adjunto"/></span>
      <a href="javascript:void(0);" class="submitSmall_02 addDocBoton" id="addDocBoton" tabindex="50"><bean:message key="Anadir_documento"/></a>
    </div>
  </div>
</div>
               
<div class="bloqueLineaAdjuntos">
  <div class="bloqueCampoAdjuntos">
    <div class="bloqueContenedorDocumento" style="float: left; height: 98%; display: none;"></div>  </div>
</div>
</fieldset>

               <div class="bloqueLinea bloqueLineaMultiple">
                  <div class="bloqueCampo bloqueCampoUnico">
                     <label for="observaciones"><bean:message key="Observaciones"/><bean:message key="Dos_Puntos"/></label>
                     <html:textarea styleId="observaciones" property="observaciones" cols="60"  rows="2" styleClass="textArea4000 bloqueCampoTextarea" tabindex="48"></html:textarea>
                  </div>
               </div>
            </fieldset>


Ayudadme. Muchas gracias.

alemag

  • Sr. Member
  • ****
  • Posts: 289
  • Karma: 0
    • View Profile
Re: bloque div que se ve bien en explorer pero no en firefox
« Reply #1 on: Septiembre 30, 2010, 09:50:49 pm »
Solucionado, cambie la etiqueta div de sitio, el codigo estaba bien, pero solo hubo que cambiar una etiqueta div, despues de varios intentos.

 

ey